Macguru

More software!

Problems with Apple Mail after upgrading from Tiger to Leopard

without comments

Something of a quick note, but anyone that has had Apple Mail just pause and hang after updating to Leopard from Tiger…. Try the following.

Quit Apple Mail and then make a copy of the ~/Library/Preferences/com.apple.mail.plist file to your desktop. Duplicate the file on your desktop for safe keeping.

Open the file in a plist editor. Now open a fresh com.apple.mail.plist file in the editor also ( Can create this by removing your current plist and just launch Apple Mail). Make anything that has to do with Junk mail in your current plist file like that in the “new” plist file. Save your changes and then copy that back into your Preference folder.

Basically the Junk Mail settings from Tiger for whatever reason cause issues in Leopard. This will hopefully fix your problem.

I’m currently tired and just wanted to jot this down before I forget. Will come back and refresh this to be more readable… lol

Written by rrhpph

October 23rd, 2009 at 12:03 pm

Disable “Firefox has just update” tab from appearing

without comments

So I decided to finally stop the madness with all of these updates and figure out how I can disable the default behavior of Firefox to let the end user know their browser has been updated. For a normal user, this is not a problem and actually probably a good thing. For a Sys Admin installing updates to labs, the lab users do not care if their browser has been updated.

Anyway, the line to change is located in the “about:config” in Firefox. Search for mstone and change the value to “ignore” for the Preference Name :
browser.startup.homepage_override.mstone

I hope this is handy for others out there. Oh, another good reference site is the following.
http://kb.mozillazine.org/Category:Preferences

Written by rrhpph

April 29th, 2009 at 10:13 am

Problems with Active Directory and Leopard — error of type -14090 (eDSAuthFailed)

without comments

So, here at CIAS we have been having problems with our Leopard Active Directory machines losing their knowledge of the directory.  We would try to unbind the machines, which would fail and require us to do a force unbind.  Then, when we go and try to rebind the machines to the directory we would always get the following message.

“Unable to add the domain.  An unexpected error of type -14090 (eDSAuthFailed) occurred.”  Wonderful….

After numerous attempts at trying to figure out what was going on, our only solution was to reimage the machine.  Not really a good solution.

Well, today I had finally decided to spend some time on this problem and try to figure out what was going on.  With some help from our local Software Engineering team I noticed that the following directory had a zero byte size file, Mainly the Kerberos plist file for our Active Directory.  Hmm, that does not sound right.

directory to look in: /var/db/dslocal/nodes/Default/config/

So, I removed the file with the zero size and then tried another rebind to the directory and it worked.  Yes!  Everything is now happy.

Command to fix (at RIT): sudo rm /var/db/dslocal/nodes/Default/config/Kerberos:MAIN.AD.RIT.EDU.plist

Written by rrhpph

January 19th, 2009 at 12:46 pm

Posted in General,Software

Enabling home directory support on 10.5 Apache

without comments

So, I had to rebuild my laptop the other day and I notice that 10.5.5 Apache does not support ~/home as an option. So, after some research (couldn’t remember how I did this before) I found the following website.

http://www.procata.com/blog/archives/2007/10/28/working-with-php-5-in-mac-os-x-105/

Basically, you have to tell apache about the home directory, since Apple disables that option.

Add a file called user.conf to /etc/apache/users/ with the following information: Of course replace “user” with the name of the actual home user you want.

 "/Users/user/Sites">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
>

Restart the Apache process: sudo apachectl restart

All good!

Written by rrhpph

October 17th, 2008 at 10:11 am

Posted in Software

Fun times

without comments

So, this past weekend I have spent countless hours trying to get our college Mac labs backup and running due to an update that I pushed out on Friday.  Of course, most of you are probably like, “Didn’t you test it”.  Of course I did, the one thing I did not test was a double restart of the system.  After debugging and debugging we could not figure out what the update did that caused the stations to not boot (Basically grey apple logo with spinning wheel).  So, only solution we had at the time was to reimage everything.  Fun… not so much.

Apple’s wonderful debugging and verbose modes were useless, especially since the machines would only boot as far as Single User mode.

We tried to 777 the whole drive to see if that would fix the problem, no go.  We knew it was permissions related, but what?

Thanks to FileWave, the problem was found.  Leopard requires the following permission on /System/Library/LaunchDaemons, 755.  In the FileSet I pushed, the permissions where set to 775.  This is where you start scratching your head. Why should that make a difference……?

Anyways, this is a good thing to know.  Oh, Apple’s own Repair Permissions utility fixes permissions inside this folder, but not the folder itself.  WHY!!  Thanks to Jay and the whole CIAS crew with helping to get our area back up and running.

Written by rrhpph

October 16th, 2008 at 9:29 am

Interesting Snow Leopard reads

without comments

Some interesting reads for anyone wondering about the upcoming OS X 10.6.

http://www.appleinsider.com/articles/08/08/26/road_to_mac_os_x_10_6_snow_leopard_64_bits.html

This is a good place on Snow Leopard developments

http://www.appleinsider.com/topics/Mac_OS_X_10.6.html

Written by rrhpph

August 26th, 2008 at 8:18 pm

Posted in Software

Great tire wall cleaner

without comments

This past weekend I was washing my truck and really wanted to clean my white lettering on my tires. Well, after some searching around the garage I noticed I was out of my normal tire cleaner. So I pondered for a minute and then decided to try my hand cleaner.

IT WORKED! The stuff actually worked and worked really well. What was it? Orange Goop hand cleaner. Stuff works on anything.

Written by rrhpph

August 18th, 2008 at 4:49 am

Posted in General

Tagged with , , , ,

mDNSResponder — Mac stuck at boot screen

without comments

So today I had a professor bring their Leopard 10.5.4 laptop back to me because it was stuck booting up.  Well, come to find out in single user mode the System log file had a whole bunch of lines like this:

—–

com.apple.launchd[1] (com.apple.mDNSResponder[53]): posix_spawnp(“/usr/sbin/mDNSResponder”, …): No such file or directory
…com.apple.launchd[1] (com.apple.mDNSResponder[53]): Exited with exit code: 1
…com.apple.launchd[1] (com.apple.mDNSResponder): Throttling respawn: Will start in 10 seconds

—–

So, after some searching I found that it probably could be permission problems.  Sure enough, I changed the permissions on the root volume to 775 and bingo the laptop now boots.  What the heck!

chmod 775 /

Written by rrhpph

August 13th, 2008 at 10:24 am

Posted in General,Software

First post from iPhone

without comments

So, this is my first post from my iPhone. Very cool application. But it is scary to think that I can post from anywhere I have signal. Very cool!

Written by rrhpph

August 4th, 2008 at 3:30 pm

Posted in General

Reset your LCD on MacBook or MacBook Pro

without comments

So, I just learned this interesting key combo tonight.  Hold down ctrl-shift-eject keys to reset your LCD to factory defaults.  Hmm….  Another hidden gem.

R

Written by rrhpph

June 19th, 2008 at 8:49 pm

Posted in Uncategorized